Problem
Batch printing or CSF generation of a PDF file format fails.
Possible Cause
This error could occur if a computer's default permission settings do not grant local launch and local activation permission for the Common Object Model (COM) server application.
Solution
If the SPFRemoteServices local user is not in the Administrator group, set the required system permissions.
-
Click Start > Control Panel > System and Security > Administrative Tools > Component Services.
You can also launch Component Services at the command prompt by typing dcomcnfg.exe.
-
In the Component Services window, expand the Component Services tree to find My Computer.
-
Right-click My Computer and click Properties.
-
From the COM Security tab on the My Computer Properties dialog box, click Edit Default under Launch and Activation Permissions.
-
Click Add and type SPFRemoteServices in the Enter the object names to select box, then click OK.
-
Select the Allow check boxes for Local Launch and Local Activation, then click OK.
Local Launch and Local Activation are required for the SPFRemoteServices local user.
-
Click OK on the My Computer Properties dialog box and exit the Component Services window.